Scheduled maintenance is still in progress. We will provide updates as necessary.
Posted Feb 05, 2026 - 16:43 EST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 05, 2026 - 16:30 EST
Scheduled
Scheduled start: Thu, Feb 5, 2026 at 4:30 PM ET Impact: No downtime expected
Description: We’re rotating the SSL/TLS certificate for go.delaware.gov. No functional changes are expected. If your systems use certificate pinning, please update pins to the new chain. Contactor your Go DE program manager if you require more information.
Posted Feb 04, 2026 - 20:41 EST
This scheduled maintenance affected: Go DE Platform Payment API - Production Environment, Go DE Payment Management Portal, and Go DE Reporting & Administration Platform.