Incident: SnapPay (Upstream Provider) Production – Intermittent Payment Failures

Incident Report for Go DE Platform

Resolved

This incident has been resolved.
Posted Jul 08, 2025 - 14:26 EDT

Monitoring

SnapPay has fixed the issue and payment transactions are flowing through now. SnapPay and the Go DE continue monitoring the issue.
Posted Jul 08, 2025 - 12:05 EDT

Investigating

We are aware of an ongoing issue with SnapPay, our upstream payment provider, which is currently experiencing intermittent failures affecting some payment transactions.

SnapPay is actively investigating the issue. As our platform relies on SnapPay to process transactions, you may experience temporary disruptions when attempting to complete a payment.

We will continue to monitor the situation and provide updates as more information becomes available from SnapPay.

We appreciate your understanding and apologize for any inconvenience.
Posted Jul 08, 2025 - 11:45 EDT
This incident affected: Go DE Platform Payment API - Production Environment.