GO DE Platform Payment Systems are degraded

Incident Report for Go DE Platform

Resolved

This incident has been resolved.
Posted Jun 06, 2026 - 08:58 EDT

Monitoring

SnapPay has reported that payment services have been restored, and Go DE payment processing is currently operating normally. Our team is continuing to monitor transactions and hosted payment page activity to confirm the system remains stable.

Users should now be able to complete payments through Go DE payment pages. We will provide another update if conditions change.
Posted Jun 06, 2026 - 08:42 EDT

Investigating

We are currently experiencing issues with payment processing due to an outage affecting SnapPay, our payment processing provider. As a result, secure payment forms are temporarily unavailable across Go DE payment pages. Users attempting to make a payment will see a notification that the payment form cannot be loaded and that no charges have been processed.
Posted Jun 06, 2026 - 07:47 EDT
This incident affected: Go DE Platform Payment API - Production Environment.